Now compatible with FSX Boxed Edition


We are very excited to announce that our products are now compatible with Microsoft FSX Boxed Edition. This requires the use of either of the following third party add-ons.

  • Mindstar GNS430/530 and G1000
  • Reality-XP GNS430/530 or GTN650/750

The new version of our plugin is now available for download on our website

 


Leave a comment


Please note, comments must be approved before they are published